gd_2.1.0.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
  2. DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
  3. complete with lines, arcs, text, multiple colors, cut and paste from other \
  4. images, and flood fills, and to write out the result as a PNG or JPEG file. \
  5. This is particularly useful in Web applications, where PNG and JPEG are two \
  6. of the formats accepted for inline images by most browsers. Note that gd is not \
  7. a paint program."
  8. HOMEPAGE = "http://libgd.bitbucket.org/"
  9. SECTION = "libs"
  10. LICENSE = "GD"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=c97638cafd3581eb87abd37332137669"
  12. DEPENDS = "freetype libpng jpeg zlib"
  13. SRC_URI = "https://bitbucket.org/libgd/gd-libgd/downloads/libgd-${PV}.tar.bz2 \
  14. file://fix-the-subdir-objects-error.patch \
  15. "
  16. SRC_URI[md5sum] = "5a1d5bab3a4a41d9f111bcceee4ad25b"
  17. SRC_URI[sha256sum] = "f3e1bc472bd81ee976a739436659fe752a14727a964c64530fde68531ddeee91"
  18. S = "${WORKDIR}/libgd-${PV}"
  19. inherit autotools binconfig gettext pkgconfig
  20. EXTRA_OECONF += " --disable-rpath \
  21. --with-jpeg=${STAGING_LIBDIR}/.. \
  22. --with-freetype=yes \
  23. --without-fontconfig \
  24. --without-xpm \
  25. --without-x"
  26. EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
  27. PACKAGES += "${PN}-tools"
  28. FILES_${PN} = "${libdir}/lib*${SOLIBS}"
  29. FILES_${PN}-tools = "${bindir}/*"
  30. PROVIDES += "${PN}-tools"
  31. RPROVIDES_${PN}-tools = "${PN}-tools"
  32. RDEPENDS_${PN}-tools = "perl perl-module-strict"