orrery_2.7.bb 1002 B

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "Astronomical application which displays the night sky"
  2. HOMEPAGE = "http://projects.openmoko.org/projects/orrery/"
  3. SECTION = "x11/scientific"
  4. LICENSE = "GPLv2+"
  5. LIC_FILES_CHKSUM = "file://orrery.c;endline=25;md5=d792bdf2b591972da175aecc38d88cfe"
  6. DEPENDS = "gtk+"
  7. inherit autotools pkgconfig
  8. SRC_URI = "http://projects.openmoko.org/frs/download.php/923/orrery_2.7_clean.tar.gz \
  9. file://orrery.png \
  10. file://use.GdkPixbuf.patch \
  11. "
  12. SRC_URI[md5sum] = "bd62a33e7554ee1030313dfcdefcda8b"
  13. SRC_URI[sha256sum] = "645166a5e05b2064ab630534a514697fc47b681951e7fe1d635c259cbdf7a5e6"
  14. S = "${WORKDIR}/${PN}"
  15. do_configure_prepend() {
  16. # fix DSO issue with binutils-2.22
  17. sed -i 's/ -lrt/ -lrt -lm/g' ${S}/Makefile.am
  18. }
  19. do_install_append() {
  20. install -d ${D}${datadir}/orrery
  21. cp -a ${S}/data/* ${D}${datadir}/orrery
  22. install -d ${D}${datadir}/icons
  23. install -m 0755 ${WORKDIR}/orrery.png ${D}${datadir}/icons
  24. }
  25. FILES_${PN} += "${datadir}/icons/orrery.png"