fim_0.4-rc1.bb 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. SUMMARY = "Framebuffer (scriptable) image viewer"
  2. DESCRIPTION = "FIM (Fbi IMproved) aims to be a highly customizable and scriptable \
  3. image viewer targeted at users who are comfortable with software \
  4. like the Vim text editor or the Mutt mail user agent."
  5. SECTION = "utils"
  6. HOMEPAGE = "http://www.autistici.org/dezperado/fim/"
  7. LICENSE = "GPLv2"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=fa01bff138cc98a62b8840a157951c88"
  9. # flex with provide /usr/include/FlexLexer.h
  10. DEPENDS = "flex-native bison-native flex"
  11. SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/fbi-improved/${BPN}-${PV}.tar.gz \
  12. file://cross_cc.patch"
  13. SRC_URI[md5sum] = "d7362dde5541c2b6439c35c6e2bd5046"
  14. SRC_URI[sha256sum] = "3f6bf2de2952b9adcbeb3db12c2a979e999a81dd1e314a03bc58e24f1ea9f686"
  15. PARALLEL_MAKE = ""
  16. inherit autotools pkgconfig
  17. # Don't use provided regex.c
  18. EXTRA_OECONF = "fim_cv_regex=no fim_cv_regex_broken=no \
  19. --enable-framebuffer \
  20. --disable-djvu \
  21. --disable-ps \
  22. --disable-xcftopnm \
  23. --disable-convert \
  24. --disable-inkscape \
  25. --disable-xfig \
  26. --disable-dia \
  27. --disable-aa \
  28. --disable-sdl \
  29. --enable-read-dirs \
  30. --enable-recursive-dirs \
  31. --enable-custom-status-bar \
  32. "
  33. # Note: imlib2 is located in meta-efl layer.
  34. PACKAGECONFIG ?= "jpeg rl hf"
  35. PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
  36. PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
  37. PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
  38. PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
  39. PACKAGECONFIG[pdf] = "--enable-poppler,--disable-poppler,poppler"
  40. PACKAGECONFIG[magick] = "--enable-graphicsmagick,--disable-graphicsmagick,imagemagick"
  41. PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
  42. PACKAGECONFIG[rl] = "--enable-readline,--disable-readline,readline"
  43. PACKAGECONFIG[hf] = "--enable-hardcoded-font,--disable-hardcoded-font"