lshw_02.19.2.bb 997 B

1234567891011121314151617181920212223242526272829303132
  1. DESCRIPTION = "A small tool to provide detailed information on the hardware \
  2. configuration of the machine. It can report exact memory configuration, \
  3. firmware version, mainboard configuration, CPU version and speed, cache \
  4. configuration, bus speed, etc. on DMI-capable or EFI systems."
  5. SUMMARY = "Hardware lister"
  6. HOMEPAGE = "http://ezix.org/project/wiki/HardwareLiSter"
  7. SECTION = "console/tools"
  8. LICENSE = "GPLv2+"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  10. COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
  11. SRC_URI = " \
  12. http://ezix.org/software/files/lshw-B.${PV}.tar.gz \
  13. file://0001-Fix-musl-build.patch \
  14. "
  15. SRC_URI[md5sum] = "8c70d46e906688309095c73ecb9396e3"
  16. SRC_URI[sha256sum] = "9bb347ac87142339a366a1759ac845e3dbb337ec000aa1b99b50ac6758a80f80"
  17. S = "${WORKDIR}/lshw-B.${PV}"
  18. do_compile() {
  19. # build core only - don't ship gui
  20. oe_runmake -C src core
  21. }
  22. do_install() {
  23. oe_runmake install DESTDIR=${D}
  24. }
  25. BBCLASSEXTEND = "native"