bonnie++_1.04.bb 868 B

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "Tests large file IO and creation/deletion of small files"
  2. HOMEPAGE = "http://www.coker.com.au/bonnie++/"
  3. SECTION = "benchmark/tests"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
  6. SRC_URI = "http://www.coker.com.au/bonnie++/${BPN}_${PV}.tgz \
  7. "
  8. SRC_URI[md5sum] = "1414aab86e2db1b4691bd4be82031012"
  9. SRC_URI[sha256sum] = "507bd2ce5360c7c98b91b0fdc2bed5c9320b5c9699f7d4a3d1c86b256896c15e"
  10. inherit autotools-brokensep
  11. SCRIPTS = "bon_csv2html bon_csv2txt"
  12. EXES = "bonnie++ zcav"
  13. TARGET_CC_ARCH += "${LDFLAGS}"
  14. do_install () {
  15. install -d ${D}/${bindir}
  16. install -d ${D}/${sbindir}
  17. install -m 0755 ${EXES} ${D}/${sbindir}
  18. install -m 0755 ${SCRIPTS} ${D}/${bindir}
  19. }
  20. PACKAGES =+ "bonnie-scripts"
  21. FILES_${PN} = "${sbindir}"
  22. FILES_bonnie-scripts = "${bindir}"
  23. RDEPENDS_bonnie-scripts += "perl"