function2_4.1.0.bb 678 B

123456789101112131415161718192021
  1. SUMMARY = "Improved drop-in replacement for std::function"
  2. DESCRIPTION = "Provides improved implementations of std::function."
  3. HOMEPAGE = "https://naios.github.io/function2"
  4. LICENSE = "BSL-1.0"
  5. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
  6. SRCREV = "3a0746bf5f601dfed05330aefcb6854354fce07d"
  7. PV .= "+git${SRCPV}"
  8. SRC_URI += "gitsm://github.com/Naios/function2"
  9. S = "${WORKDIR}/git"
  10. inherit cmake
  11. inherit ptest
  12. # Installs some data to incorrect top-level /usr directory
  13. do_install_append() {
  14. mkdir -p ${D}/${datadir}/function2
  15. mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/
  16. mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/
  17. }