properties-cpp_git.bb 602 B

12345678910111213141516171819202122
  1. # Copyright (c) 2019 Christophe Chapuis <chris.chapuis@gmail.com>
  2. # Copyright (c) 2019 Herman van Hazendonk <github.com@herrie.org>
  3. SUMMARY = "A very simple convenience library for handling properties and signals in C++11."
  4. SECTION = "libs"
  5. LICENSE = "LGPLv3"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
  7. PV = "0.0.1+git${SRCPV}"
  8. SRCREV = "45863e849b39c4921d6553e6d27e267a96ac7d77"
  9. SRC_URI = "git://github.com/lib-cpp/${BPN}.git"
  10. S = "${WORKDIR}/git"
  11. do_configure_prepend() {
  12. echo " " > ${S}/tests/CMakeLists.txt
  13. }
  14. inherit cmake pkgconfig
  15. RDEPENDS_${PN}-dev = ""