ne10_1.2.1.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. DESCRIPTION = "Library containing NEON-optimized implementations for a common set of functions"
  2. HOMEPAGE = "http://projectne10.github.io/Ne10/"
  3. LICENSE = "BSD-3-Clause"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=e7fe20c9be97be5579e3ab5d92d3a218"
  5. SECTION = "libs"
  6. SRC_URI = "git://github.com/projectNe10/Ne10.git \
  7. file://0001-CMakeLists.txt-Remove-mthumb-interwork.patch \
  8. file://0001-Dont-specify-march-explicitly.patch \
  9. "
  10. SRCREV = "18c4c982a595dad069cd8df4932aefb1d257591f"
  11. S = "${WORKDIR}/git"
  12. PV .= "gitr+${SRCPV}"
  13. inherit cmake
  14. # Incompatible with archs other than armv7, armv7ve and aarch64
  15. COMPATIBLE_MACHINE = "(^$)"
  16. COMPATIBLE_MACHINE_aarch64 = "(.*)"
  17. COMPATIBLE_MACHINE_armv7a = "(.*)"
  18. COMPATIBLE_MACHINE_armv7ve = "(.*)"
  19. NE10_TARGET_ARCH = ""
  20. NE10_TARGET_ARCH_aarch64 = "aarch64"
  21. NE10_TARGET_ARCH_armv7a = "armv7"
  22. NE10_TARGET_ARCH_armv7ve = "armv7"
  23. EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"'
  24. do_install() {
  25. install -d ${D}${libdir}
  26. install -d ${D}${includedir}
  27. install -m 0644 ${S}/inc/NE10*.h ${D}${includedir}/
  28. install -m 0644 ${B}/modules/libNE10.a ${D}${libdir}/
  29. install -m 0755 ${B}/modules/libNE10.so.* ${D}${libdir}/
  30. cp -d ${B}/modules/libNE10.so ${D}${libdir}/
  31. }
  32. # ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations in .text [textrel]
  33. # ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations in .text [textrel]
  34. INSANE_SKIP_${PN} += "textrel"