libopus_1.1.3.bb 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. SUMMARY = "Opus Audio Codec"
  2. DESCRIPTION = "The Opus codec is designed for interactive \
  3. speech and audio transmission over the Internet. It is \
  4. designed by the IETF Codec Working Group and incorporates \
  5. technology from Skype's SILK codec and Xiph.Org's CELT codec."
  6. HOMEPAGE = "http://www.opus-codec.org/"
  7. SECTION = "libs/multimedia"
  8. LICENSE = "BSD"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3"
  10. SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz"
  11. SRC_URI[md5sum] = "32bbb6b557fe1b6066adc0ae1f08b629"
  12. SRC_URI[sha256sum] = "58b6fe802e7e30182e95d0cde890c0ace40b6f125cffc50635f0ad2eef69b633"
  13. S = "${WORKDIR}/opus-${PV}"
  14. inherit autotools pkgconfig
  15. PACKAGECONFIG ??= ""
  16. PACKAGECONFIG[fixed-point] = "--enable-fixed-point,,"
  17. PACKAGECONFIG[float-approx] = "--enable-float-approx,,"
  18. EXTRA_OECONF = " \
  19. --with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \
  20. --with-NE10-libraries=${STAGING_DIR_TARGET}${libdir} \
  21. --enable-asm \
  22. --enable-intrinsics \
  23. --enable-custom-modes \
  24. "
  25. # ne10 is available only for armv7a, armv7ve and aarch64
  26. DEPENDS_append_aarch64 = " ne10"
  27. DEPENDS_append_armv7a = " ne10"
  28. DEPENDS_append_armv7ve = " ne10"
  29. python () {
  30. if d.getVar('TARGET_FPU') in [ 'soft' ]:
  31. d.appendVar('PACKAGECONFIG', ' fixed-point')
  32. }
  33. # Fails to build with thumb-1 (qemuarm)
  34. #| {standard input}: Assembler messages:
  35. #| {standard input}:389: Error: selected processor does not support Thumb mode `smull r5,r7,r1,r4'
  36. #| {standard input}:418: Error: selected processor does not support Thumb mode `smull r5,r6,r4,r1'
  37. #| {standard input}:448: Error: selected processor does not support Thumb mode `smull r4,r5,r1,r0'
  38. #| {standard input}:474: Error: selected processor does not support Thumb mode `smull r0,r4,r8,r1'
  39. #| {standard input}:510: Error: selected processor does not support Thumb mode `smull fp,r0,r10,r1'
  40. #| {standard input}:553: Error: selected processor does not support Thumb mode `smull fp,r1,r10,r3'
  41. #| {standard input}:741: Error: selected processor does not support Thumb mode `smull r3,r0,r6,r10'
  42. #| {standard input}:761: Error: selected processor does not support Thumb mode `smull fp,r2,r3,r9'
  43. #| {standard input}:773: Error: selected processor does not support Thumb mode `smull fp,r3,r5,r8'
  44. #| make[2]: *** [celt/celt.lo] Error 1
  45. ARM_INSTRUCTION_SET = "arm"
  46. BBCLASSEXTEND = "native nativesdk"