libnet-ssleay-perl_1.85.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL"
  2. DESCRIPTION = "This module offers some high level convenience functions for accessing \
  3. web pages on SSL servers (for symmetry, same API is offered for \
  4. accessing http servers, too), a sslcat() function for writing your own \
  5. clients, and finally access to the SSL api of SSLeay/OpenSSL package \
  6. so you can write servers or clients for more complicated applications."
  7. HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/"
  8. SECTION = "libs"
  9. LICENSE = "Artistic-1.0 | GPL-1.0+"
  10. LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e"
  11. DEPENDS = "openssl zlib openssl-native"
  12. RDEPENDS_${PN} += "\
  13. libssl \
  14. libcrypto \
  15. perl-module-carp \
  16. perl-module-errno \
  17. perl-module-extutils-makemaker \
  18. perl-module-mime-base64 \
  19. perl-module-socket \
  20. zlib \
  21. "
  22. SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
  23. file://no-exec-on-configure.patch \
  24. file://run-ptest \
  25. "
  26. SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69"
  27. SRC_URI[sha256sum] = "9d8188b9fb1cae3bd791979c20554925d5e94a138d00414f1a6814549927b0c8"
  28. S = "${WORKDIR}/Net-SSLeay-${PV}"
  29. inherit cpan ptest
  30. do_configure() {
  31. export OPENSSL_PREFIX="${STAGING_EXECPREFIXDIR}"
  32. cpan_do_configure
  33. }
  34. do_install_ptest() {
  35. cp -r ${B}/t ${D}${PTEST_PATH}
  36. }
  37. FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/"
  38. RDEPENDS_${PN}-ptest = " perl"