libnet-ldap-perl_0.67.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. SUMMARY = "LDAP Perl module"
  2. DESCRIPTION = "Net::LDAP is a collection of modules that implements \
  3. a LDAP services API for Perl programs. The module may be used to \
  4. search directories or perform maintenance functions such as adding, \
  5. deleting or modifying entries."
  6. SECTION = "libs"
  7. LICENSE = "Artistic-1.0|GPLv1+"
  8. LIC_FILES_CHKSUM = "file://README;beginline=3;endline=5;md5=4d6588c2fa0d38ae162f6314d201d89e"
  9. SRC_URI = "${CPAN_MIRROR}/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz"
  10. SRC_URI[md5sum] = "a949a2bab07b44cc043b965485fe493a"
  11. SRC_URI[sha256sum] = "19a2f7f7959fe23d16367475772c325109f8604d2949e34b96dddb2dfa031170"
  12. S = "${WORKDIR}/perl-ldap-${PV}"
  13. inherit cpan ptest-perl
  14. do_configure_prepend() {
  15. perl -pi -e 's/auto_install_now.*//g' Makefile.PL
  16. }
  17. do_install_ptest() {
  18. cp -r ${B}/data ${D}${PTEST_PATH}
  19. chown -R root:root ${D}${PTEST_PATH}
  20. }
  21. RDEPENDS_${PN} += " \
  22. libconvert-asn1-perl \
  23. libio-socket-ssl-perl \
  24. libauthen-sasl-perl \
  25. perl-module-integer \
  26. "
  27. RDEPENDS_${PN}-ptest += " \
  28. libxml-sax-base-perl \
  29. libxml-sax-writer-perl \
  30. perl-module-file-compare \
  31. perl-module-perlio \
  32. perl-module-test-more \
  33. "
  34. BBCLASSEXTEND = "native"