debootstrap_1.0.67.bb 1.0 KB

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "Install a Debian system into a subdirectory"
  2. HOMEPAGE = "https://wiki.debian.org/Debootstrap"
  3. SECTION = "devel"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608"
  6. inherit pkgconfig
  7. SRC_URI = "\
  8. http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \
  9. file://devices.tar.gz;unpack=0 \
  10. "
  11. SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a"
  12. SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b"
  13. S = "${WORKDIR}/${BP}"
  14. # All Makefile does is creation of devices.tar.gz, which fails in OE build, we use
  15. # static devices.tar.gz as work around
  16. # | NOTE: make -j 8 -e MAKEFLAGS=
  17. # | rm -rf dev
  18. # | mkdir -p dev
  19. # | chown 0:0 dev
  20. # | chown: changing ownership of `dev': Operation not permitted
  21. # | make: *** [devices.tar.gz] Error 1
  22. # | WARNING: exit code 1 from a shell command.
  23. do_compile_prepend() {
  24. cp ${WORKDIR}/devices.tar.gz ${B}
  25. }
  26. do_install() {
  27. oe_runmake 'DESTDIR=${D}' install
  28. chown -R root:root ${D}${datadir}/debootstrap
  29. }