traceroute_2.1.0.bb 1.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
  2. DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
  3. their way to a specified network (or Internet) host. Traceroute displays \
  4. the IP number and host name (if possible) of the machines along the \
  5. route taken by the packets. Traceroute is used as a network debugging \
  6. tool. If you're having network connectivity problems, traceroute will \
  7. show you where the trouble is coming from along the route."
  8. SECTION = "net"
  9. HOMEPAGE = "http://traceroute.sourceforge.net/"
  10. LICENSE = "GPL-2.0+ & LGPL-2.1+"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
  12. file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
  13. inherit update-alternatives
  14. UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/traceroute/files/traceroute/"
  15. SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
  16. "
  17. SRC_URI[md5sum] = "84d329d67abc3fb83fc8cb12aeaddaba"
  18. SRC_URI[sha256sum] = "3669d22a34d3f38ed50caba18cd525ba55c5c00d5465f2d20d7472e5d81603b6"
  19. LTOEXTRA += "-flto-partition=none"
  20. do_compile() {
  21. oe_runmake "env=yes"
  22. }
  23. do_install() {
  24. install -d ${D}${bindir}
  25. install -m755 ${BPN}/${BPN} ${D}${bindir}
  26. install -m755 wrappers/tcptraceroute ${D}${bindir}
  27. install -d ${D}${mandir}/man8
  28. install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}/man8
  29. ln -s ${BPN}.8 ${D}${mandir}/man8/${BPN}6.8
  30. ln -s ${BPN}.8 ${D}${mandir}/man8/tcptraceroute.8
  31. }
  32. ALTERNATIVE_PRIORITY = "60"
  33. ALTERNATIVE_${PN} = "traceroute"
  34. ALTERNATIVE_LINK_NAME[traceroute] = "${bindir}/traceroute"