libxml-libxml-perl_2.0121.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. SUMMARY = "Perl interface to the libxml2 library"
  2. DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \
  3. with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \
  4. interface and a XML::XPath-like interface to XPath API of libxml2. \
  5. The module is split into several packages which are not described in this \
  6. section; unless stated otherwise, you only need to use XML::LibXML; in \
  7. your programs."
  8. HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/"
  9. SECTION = "libs"
  10. LICENSE = "Artistic-1.0|GPLv1+"
  11. DEPENDS += "libxml2 \
  12. libxml-sax-perl-native \
  13. zlib \
  14. "
  15. RDEPENDS_${PN} += "libxml2 \
  16. libxml-sax-perl \
  17. libxml-sax-base-perl \
  18. zlib \
  19. "
  20. SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \
  21. file://disable-libxml2-check.patch \
  22. file://fix-CATALOG-conditional-compile.patch \
  23. file://using-DOCB-conditional.patch \
  24. "
  25. LIC_FILES_CHKSUM = "file://debian/copyright;md5=75e021e35a906347f46c9ff163653e2a \
  26. file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \
  27. "
  28. SRC_URI[libxml.md5sum] = "1544ab9ac110f5da296015346561ce02"
  29. SRC_URI[libxml.sha256sum] = "ec431011cb37a04640fd2316f64d0405a274eece2c6f3847f7fbd336eb1c0dc9"
  30. S = "${WORKDIR}/XML-LibXML-${PV}"
  31. inherit cpan
  32. EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
  33. BBCLASSEXTEND = "native"
  34. CFLAGS += " -D_GNU_SOURCE "
  35. BUILD_CFLAGS += " -D_GNU_SOURCE "
  36. FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"