libmodule-pluggable-perl_5.2.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "Automatically give your module the ability to have plugins"
  2. DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
  3. having 'plugins' for your module. Obviously this isn't going to be the \
  4. be all and end all of solutions but it works for me.\
  5. \
  6. Essentially all it does is export a method into your namespace that \
  7. looks through a search path for .pm files and turn those into class \
  8. names.\
  9. \
  10. Optionally it instantiates those classes for you."
  11. SECTION = "libs"
  12. AUTHOR = "Simon Wistow <simon@thegestalt.org>"
  13. HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
  14. LICENSE = "Artistic-1.0 | GPL-1.0+"
  15. LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
  16. SRCNAME = "Module-Pluggable"
  17. SRC_URI = "https://github.com/moto-timo/${SRCNAME}/archive/${PV}.tar.gz"
  18. SRC_URI[md5sum] = "e32475d6ff5843f738cedacd3b7a2cdb"
  19. SRC_URI[sha256sum] = "58c62292eea6d06959eba1b97598650813211265403242d57efb2f605c96059f"
  20. S = "${WORKDIR}/${SRCNAME}-${PV}"
  21. inherit cpan
  22. RDEPENDS_${PN} = " perl-module-base \
  23. perl-module-deprecate \
  24. perl-module-file-basename \
  25. perl-module-file-find \
  26. perl-module-file-spec \
  27. perl-module-file-spec-functions \
  28. perl-module-if \
  29. perl-module-test-more \
  30. "
  31. BBCLASSEXTEND = "native"