numactl_2.0.11.bb 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. SUMMARY = "Development package for building Applications that use numa"
  2. DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
  3. to run other programs with a specific NUMA policy and a libnuma to do \
  4. allocations with NUMA policy in applications."
  5. LICENSE = "GPL-2.0 & LGPL-2.1"
  6. SECTION = "apps"
  7. RDEPENDS_${PN} = "perl"
  8. inherit autotools-brokensep ptest
  9. LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9"
  10. SRC_URI = "ftp://oss.sgi.com/www/projects/libnuma/download/${BPN}-${PV}.tar.gz \
  11. file://fix-null-pointer.patch \
  12. file://Fix-the-test-output-format.patch \
  13. file://Makefile \
  14. file://run-ptest \
  15. file://0001-define-run-test-target.patch \
  16. "
  17. SRC_URI[md5sum] = "d3bc88b7ddb9f06d60898f4816ae9127"
  18. SRC_URI[sha256sum] = "450c091235f891ee874a8651b179c30f57a1391ca5c4673354740ba65e527861"
  19. # ARM does not currently support NUMA
  20. COMPATIBLE_HOST = "^((?!arm).*)$"
  21. do_install() {
  22. oe_runmake DESTDIR=${D} prefix=${D}/usr install
  23. #remove the empty man2 directory
  24. rm -r ${D}${mandir}/man2
  25. }
  26. do_compile_ptest() {
  27. oe_runmake test
  28. }
  29. do_install_ptest() {
  30. #install tests binaries
  31. local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
  32. mynode nodemap node-parse pagesize prefered randmap realloc_test \
  33. tbitmap tshared"
  34. [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
  35. for i in $test_binaries; do
  36. install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
  37. done
  38. local test_scripts="checktopology checkaffinity printcpu regress regress2 \
  39. shmtest runltp bind_range"
  40. for i in $test_scripts; do
  41. install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
  42. done
  43. install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
  44. install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
  45. }
  46. RDEPENDS_${PN}-ptest = "bash"