wayland-fits_git.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "Wayland-fits, the Wayland Functional Integration Test Suite"
  2. DESCRIPTION = "Wayland-fits is a fully automated functional integration \
  3. test suite. Its main purpose is to test the functionality and integration of \
  4. client-side (i.e. toolkit) and server-side (compositor) implementations of \
  5. the Wayland protocol."
  6. HOMEPAGE = "https://github.com/01org/wayland-fits"
  7. LICENSE = "MIT"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=f8d34cadaf891753c0f00c6cd48f08f5 \
  9. file://src/extensions/weston/weston-wfits.cpp;endline=21;md5=848c81e55cf3a30a9f6ed75f0dba7a97"
  10. SRC_URI = "git://github.com/01org/wayland-fits.git"
  11. SRCREV = "f108335e374772ae2818a30ae37fe6fcda81980f"
  12. S = "${WORKDIR}/git"
  13. inherit autotools pkgconfig
  14. DEPENDS = "libcheck boost wayland weston"
  15. RDEPENDS_${PN} = "weston"
  16. EXTRA_OECONF += "--enable-shared --disable-static --with-boost-libdir=${STAGING_LIBDIR}"
  17. PACKAGECONFIG ?= "gtk+3"
  18. PACKAGECONFIG[elementary] = "--enable-efl-tests,--disable-efl-tests,elementary"
  19. PACKAGECONFIG[gtk+3] = "--enable-gtk-tests,--disable-gtk-tests,gtk+3"
  20. do_install_append() {
  21. rm -f ${D}/${libdir}/weston/*.la
  22. }
  23. FILES_${PN} += "${bindir}/wfits ${libdir}/weston/*.so"
  24. FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/weston/.debug ${prefix}/src"