haveged_1.9.1.bb 1.1 KB

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "haveged - A simple entropy daemon"
  2. DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
  3. AUTHOR = "Gary Wuertz"
  4. HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
  5. LICENSE = "GPLv3"
  6. LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  7. SRC_URI = "http://www.issihosts.com/haveged/haveged-${PV}.tar.gz \
  8. file://remove-systemd-unit-503.patch \
  9. "
  10. SRC_URI[md5sum] = "015ff58cd10607db0e0de60aeca2f5f8"
  11. SRC_URI[sha256sum] = "9c2363ed9542a6784ff08e247182137e71f2ddb79e8e6c1ac4ad50d21ced3715"
  12. PR = "r0"
  13. inherit autotools systemd
  14. EXTRA_OECONF = "\
  15. --enable-init=service.redhat \
  16. --enable-nistest=yes \
  17. --enable-olt=yes \
  18. --enable-threads=no \
  19. "
  20. SYSTEMD_PACKAGES = "${PN}"
  21. SYSTEMD_SERVICE_${PN} = "haveged.service"
  22. do_install_append() {
  23. mkdir -p ${D}${systemd_unitdir}/system
  24. install -p -m644 ${B}/init.d/haveged.service ${D}${systemd_unitdir}/system
  25. }