mpich_3.1.1.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "Message Passing Interface (MPI) implementation"
  2. HOMEPAGE = "http://www.mpich.org/"
  3. SECTION = "devel"
  4. LICENSE = "BSD-2-Clause"
  5. LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=2106f0435056f3dd9349747a766e5816"
  6. SRC_URI = " \
  7. http://www.mpich.org/static/downloads/${PV}/mpich-${PV}.tar.gz \
  8. "
  9. SRC_URI[md5sum] = "40dc408b1e03cc36d80209baaa2d32b7"
  10. SRC_URI[sha256sum] = "455ccfaf4ec724d2cf5d8bff1f3d26a958ad196121e7ea26504fd3018757652d"
  11. CACHED_CONFIGUREVARS += "BASH_SHELL=${base_bindir}/bash"
  12. RDEPENDS_${PN} += "bash perl libxml2"
  13. S = "${WORKDIR}/${BP}"
  14. EXTRA_OECONF = "--enable-debuginfo \
  15. --enable-fast \
  16. --enable-shared \
  17. --with-pm=gforker \
  18. --disable-rpath \
  19. --disable-f77 \
  20. --disable-fc \
  21. --disable-fortran \
  22. --disable-cxx \
  23. "
  24. inherit autotools-brokensep gettext
  25. do_configure_prepend() {
  26. autoreconf --verbose --install --force -I . -I confdb/ -I maint/
  27. oe_runconf
  28. exit
  29. }
  30. # http://errors.yoctoproject.org/Errors/Details/35146/
  31. PNBLACKLIST[mpich] ?= "BROKEN: QA Issue: libmpi.la failed sanity test (workdir), QA Issue: mpich.pc failed sanity test (tmpdir)"