plymouth_0.9.2.bb 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
  2. DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
  3. (even before the root filesystem is mounted!) that provides a \
  4. graphical boot animation while the boot process happens in the background. \
  5. "
  6. HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
  7. SECTION = "base"
  8. LICENSE = "GPLv2+"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  10. DEPENDS = "libcap libpng cairo dbus udev"
  11. PROVIDES = "virtual/psplash"
  12. RPROVIDES_${PN} = "virtual/psplash virtual/psplash-support"
  13. SRC_URI = "http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.bz2"
  14. SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d"
  15. SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f"
  16. EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
  17. --with-logo=${LOGO} \
  18. ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
  19. "
  20. PACKAGECONFIG ??= "pango initrd"
  21. PACKAGECONFIG_append_x86 = " drm"
  22. PACKAGECONFIG_append_x86-64 = " drm"
  23. PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
  24. PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
  25. PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+"
  26. PACKAGECONFIG[initrd] = ",,,"
  27. LOGO ??= "${datadir}/plymouth/bizcom.png"
  28. inherit autotools pkgconfig systemd
  29. do_install_append() {
  30. install -d ${D}${systemd_unitdir}/system
  31. install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
  32. install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
  33. # Remove /var/run from package as plymouth will populate it on startup
  34. rm -fr "${D}${localstatedir}/run"
  35. if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
  36. rm -rf "${D}${libexecdir}"
  37. fi
  38. }
  39. PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
  40. PACKAGES =+ "${PN}-set-default-theme"
  41. FILES_${PN}-initrd = "${libexecdir}/plymouth/*"
  42. FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
  43. FILES_${PN} += "${systemd_unitdir}/system/*"
  44. FILES_${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
  45. RDEPENDS_${PN}-initrd = "bash dracut"
  46. RDEPENDS_${PN}-set-default-theme = "bash"
  47. SYSTEMD_SERVICE_${PN} = "plymouth-start.service"