smstools3_3.1.15.bb 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. SUMMARY = "SMS Gateway software"
  2. DESCRIPTION = "The SMS Server Tools 3 is a SMS Gateway software which can send and receive short messages through GSM modems and mobile phones."
  3. SECTION = "console/network"
  4. LICENSE = "GPLv2"
  5. LIC_FILES_CHKSUM = "file://LICENSE;md5=4d21efa1bb2a186360dde4035f860682"
  6. HOMEPAGE = "http://smstools3.kekekasvi.com"
  7. SRC_URI = "http://smstools3.kekekasvi.com/packages/${BP}.tar.gz \
  8. file://sms_binpath_and_psops.patch \
  9. file://fix-makefile-override.patch"
  10. SRC_URI[md5sum] = "0241ef60e646fac1a06254a848e61ed7"
  11. SRC_URI[sha256sum] = "ed00ffaeaa312a5b4f969f4e97a64603a866bbe16e393ea02f5bf05234814d59"
  12. S = "${WORKDIR}/${BPN}"
  13. RDEPENDS_${PN} = "bash"
  14. INITSCRIPT_NAME = "sms3"
  15. INITSCRIPT_PARAMS = "defaults"
  16. inherit update-rc.d
  17. do_install () {
  18. install -d ${D}${bindir}
  19. install -m 755 ${S}/src/smsd "${D}${bindir}/smsd"
  20. install -m 755 ${S}/scripts/sendsms "${D}${bindir}/sendsms"
  21. install -m 755 ${S}/scripts/sms2html "${D}${bindir}/sms2html"
  22. install -m 755 ${S}/scripts/sms2unicode "${D}${bindir}/sms2unicode"
  23. install -m 755 ${S}/scripts/unicode2sms "${D}${bindir}/unicode2sms"
  24. install -d ${D}${sysconfdir}
  25. install -m 644 ${S}/examples/smsd.conf.easy "${D}${sysconfdir}/smsd.conf"
  26. install -d "${D}${localstatedir}/spool"
  27. install -d "${D}${localstatedir}/spool/sms"
  28. install -d "${D}${localstatedir}/spool/sms/incoming"
  29. install -d "${D}${localstatedir}/spool/sms/outgoing"
  30. install -d "${D}${localstatedir}/spool/sms/checked"
  31. install -d ${D}${sysconfdir}/init.d
  32. install -m 755 ${S}/scripts/sms3 "${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}"
  33. }