mosh_1.2.4.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # NOTE: mosh-server requires a UTF-8 locale, but there's no way to add
  2. # an explicit dependency for this so you need to ensure this is in your
  3. # image yourself when you install mosh-server.
  4. SUMMARY = "Remote shell supporting roaming and high-latency connections"
  5. DESCRIPTION = "Remote terminal application that allows roaming, supports \
  6. intermittent connectivity, and provides intelligent local echo and line \
  7. editing of user keystrokes. Mosh is a replacement for SSH. It's more \
  8. robust and responsive, especially over Wi-Fi, cellular, and \
  9. long-distance links."
  10. HOMEPAGE = "http://mosh.mit.edu"
  11. LICENSE = "GPLv3+"
  12. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  13. DEPENDS = "protobuf-native protobuf ncurses zlib libio-pty-perl openssl libutempter"
  14. SRC_URI = "http://mosh.mit.edu/mosh-${PV}.tar.gz"
  15. SRC_URI[md5sum] = "c2d918f4d91fdc32546e2e089f9281b2"
  16. SRC_URI[sha256sum] = "e74d0d323226046e402dd469a176075fc2013b69b0e67cea49762c957175df46"
  17. inherit autotools
  18. PACKAGE_BEFORE_PN += "${PN}-server"
  19. FILES_${PN}-server = "${bindir}/mosh-server"
  20. NEEDED_PERL_MODULES = "\
  21. perl-module-socket \
  22. perl-module-getopt-long \
  23. perl-module-errno \
  24. perl-module-io-socket-inet \
  25. perl-module-posix \
  26. "
  27. # mosh uses SSH to authenticate and the client uses OpenSSH-specific features
  28. RDEPENDS_${PN} += "openssh-ssh ${NEEDED_PERL_MODULES}"
  29. # The server seemed not to work with dropbear either
  30. RDEPENDS_${PN}-server += "openssh-sshd ${NEEDED_PERL_MODULES}"
  31. # Fails to build with thumb-1 (qemuarm)
  32. #| {standard input}: Assembler messages:
  33. #| {standard input}:2100: Error: instruction not supported in Thumb16 mode -- `adds r4,r4,r4'
  34. #| {standard input}:2101: Error: instruction not supported in Thumb16 mode -- `adcs r5,r5,r5'
  35. #| {standard input}:2102: Error: instruction not supported in Thumb16 mode -- `adcs r6,r6,r6'
  36. #| {standard input}:2103: Error: instruction not supported in Thumb16 mode -- `adcs r7,r7,r7'
  37. #| {standard input}:2104: Error: selected processor does not support Thumb mode `it cs'
  38. ARM_INSTRUCTION_SET = "arm"