analyze-suspend_git.bb 1020 B

1234567891011121314151617181920212223242526272829
  1. SUMMARY = "Analyze Suspend"
  2. DESCRIPTION = "analyze-suspend is a tool for system developers to visualize \
  3. the activity between suspend and resume, allowing them to identify \
  4. inefficiencies and bottlenecks."
  5. HOMEPAGE = "https://01.org/suspendresume"
  6. LICENSE = "GPLv2"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
  8. # Apart from the listed RDEPENDS, analyze-suspend depends on some features
  9. # provided by the kernel. These options are:
  10. # - CONFIG_PM_DEBUG=y
  11. # - CONFIG_PM_SLEEP_DEBUG=y
  12. # - CONFIG_FTRACE=y
  13. # - CONFIG_FUNCTION_TRACER=y
  14. # - CONFIG_FUNCTION_GRAPH_TRACER=y
  15. RDEPENDS_${PN} += "python-core python-datetime python-stringold"
  16. PV = "3.2+gitr${SRCPV}"
  17. SRCREV = "c669e002a2e7504f21e277ad248fa81033926391"
  18. SRC_URI = "git://github.com/01org/suspendresume.git;protocol=https"
  19. S = "${WORKDIR}/git"
  20. do_install() {
  21. install -Dm 0755 analyze_suspend.py ${D}${bindir}/analyze_suspend.py
  22. install -Dm 0644 README ${D}${docdir}/analyze-suspend/README
  23. }
  24. BBCLASSEXTEND = "native"