tcpslice_1.2a3.bb 1.0 KB

123456789101112131415161718192021222324252627282930313233343536
  1. SUMMARY = "tcpslice"
  2. DESCRIPTION = "A tool for extracting parts of a tcpdump packet trace."
  3. HOMEPAGE = "http://www.tcpdump.org/related.html"
  4. SECTION = "net"
  5. LICENSE = "BSD-4-Clause"
  6. LIC_FILES_CHKSUM = "file://tcpslice.c;endline=20;md5=99519e2e5234d1662a4ce16baa62c64e"
  7. SRC_URI = "ftp://ftp.ee.lbl.gov/${BP}.tar.gz \
  8. file://tcpslice-1.2a3-time.patch \
  9. file://tcpslice-CVS.20010207-bpf.patch \
  10. "
  11. SRC_URI[md5sum] = "e329cbeb7e589f132d92c3447c477190"
  12. SRC_URI[sha256sum] = "4096e8debc898cfaa16b5306f1c42f8d18b19e30e60da8d4deb781c8f684c840"
  13. inherit autotools-brokensep
  14. DEPENDS += "libpcap"
  15. # We do not want to autoreconf. We must specify srcdir as ".".
  16. # We have to set the ac_cv_* cache variables as well as pass the normal
  17. # cross-compilation options to configure!
  18. #
  19. do_configure () {
  20. oe_runconf \
  21. --srcdir="." \
  22. ac_cv_build=${BUILD_SYS} \
  23. ac_cv_host=${HOST_SYS} \
  24. ac_cv_target=${HOST_SYS}
  25. }
  26. do_install () {
  27. mkdir -p ${D}/usr/sbin
  28. install -c -m 555 tcpslice ${D}/usr/sbin
  29. }