geoip-perl_1.45.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. #
  2. # Copyright (C) 2014, 2015 Wind River Systems, Inc.
  3. # Released under the MIT license (see COPYING.MIT for the terms)
  4. #
  5. SUMMARY = "GeoIP perl API library to access location database"
  6. DESCRIPTION = "perl library for country/city/organization to IP address or hostname mapping"
  7. HOMEPAGE = "http://www.maxmind.com/app/ip-location"
  8. SECTION = "libdevel"
  9. LICENSE = "Artistic-1.0 | GPL-1.0+"
  10. LIC_FILES_CHKSUM = "file://README;md5=b0fa745303912bd2d64430f7ae69487d"
  11. # Note that we do not want to use the upstream file name locally.
  12. #
  13. SRC_URI = "http://github.com/maxmind/geoip-api-perl/archive/v${PV}.tar.gz;downloadfilename=${BPN}-${PV}.tar.gz \
  14. file://run-ptest \
  15. "
  16. SRC_URI[md5sum] = "0ce57140890bf81958e0cea4fe1885b2"
  17. SRC_URI[sha256sum] = "c56437b1cc8887736cb1e435d0320c1c1ff3754830249516317b99137005fb23"
  18. S = "${WORKDIR}/geoip-api-perl-${PV}"
  19. DEPENDS += "geoip"
  20. inherit cpan ptest
  21. EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'"
  22. # perl scripts and some special small data files
  23. #
  24. do_install_ptest () {
  25. install -d -m 0755 ${D}${PTEST_PATH}/t/data
  26. install ${S}/t/*.t* ${D}${PTEST_PATH}/t
  27. install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
  28. }
  29. FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"