autofs_5.1.1.bb 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. SUMMARY = "Kernel based automounter for linux"
  2. SECTION = "utils"
  3. LICENSE = "GPL-2.0"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
  5. DEPENDS += "libtirpc flex-native bison-native"
  6. inherit autotools-brokensep systemd
  7. SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
  8. file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \
  9. file://no-bash.patch \
  10. file://cross.patch \
  11. file://libtirpc.patch \
  12. file://libtirpc-name-clash-backout.patch \
  13. file://autofs-5.0.7-do-not-check-for-modprobe.patch \
  14. file://fix_disable_ldap.patch \
  15. file://autofs-5.0.7-fix-lib-deps.patch \
  16. file://add-the-needed-stdarg.h.patch \
  17. file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \
  18. file://force-STRIP-to-emtpy.patch \
  19. file://remove-bashism.patch \
  20. file://fix-the-YACC-rule-to-fix-a-building-failure.patch \
  21. "
  22. SRC_URI[md5sum] = "e143df66b614b8cdb1ff533735f8e12d"
  23. SRC_URI[sha256sum] = "795419383b120d15699ab3b89ea0f3d029f6fb28405a83982d305c4b7b61130f"
  24. inherit update-rc.d pkgconfig
  25. INITSCRIPT_NAME = "autofs"
  26. INITSCRIPT_PARAMS = "defaults"
  27. # FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
  28. CFLAGS += "${LDFLAGS}"
  29. PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
  30. PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
  31. EXTRA_OEMAKE = "DONTSTRIP=1"
  32. EXTRA_OECONF += "--disable-mount-locking \
  33. --enable-ignore-busy --with-openldap=no \
  34. --with-sasl=no --with-libtirpc=yes \
  35. --with-path=${STAGING_BINDIR_NATIVE} \
  36. "
  37. CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
  38. ac_cv_path_RPCGEN=rpcgen \
  39. "
  40. do_configure_prepend () {
  41. sed -e "s:filagdir:flagdir:" -i configure.in
  42. if [ ! -e acinclude.m4 ]; then
  43. cp aclocal.m4 acinclude.m4
  44. fi
  45. }
  46. do_install_append () {
  47. if [ -d ${D}/run ]; then
  48. rmdir ${D}/run
  49. fi
  50. if [ -d ${D}${localstatedir}/run ]; then
  51. rmdir ${D}${localstatedir}/run
  52. fi
  53. }
  54. INSANE_SKIP_${PN} = "dev-so"
  55. RPROVIDES_${PN} += "${PN}-systemd"
  56. RREPLACES_${PN} += "${PN}-systemd"
  57. RCONFLICTS_${PN} += "${PN}-systemd"
  58. SYSTEMD_SERVICE_${PN} = "autofs.service"