grubby_8.40.bb 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. SUMMARY = "A command line tool for updating and displaying info about boot loaders"
  2. DESCRIPTION = "grubby is a command line tool for updating and displaying information \
  3. about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
  4. zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
  5. new kernels and need to find information about the current boot environment. \
  6. "
  7. LICENSE = "GPLv2+"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
  9. DEPENDS = "popt util-linux"
  10. SRC_URI = "https://github.com/rhinstaller/${BPN}/archive/${PV}-1.tar.gz;downloadfilename=${BPN}-${PV}-1.tar.gz \
  11. file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
  12. file://run-ptest \
  13. file://grubby-remove-bashisms-in-test.sh.patch \
  14. "
  15. SRC_URI[md5sum] = "1005907b275d6d93368d045274537d86"
  16. SRC_URI[sha256sum] = "85f1c678484f74c8978e8643451594967defce463a86c35cb1ee56d12767a9df"
  17. S = "${WORKDIR}/${BPN}-${PV}-1"
  18. RDEPENDS_${PN} += "dracut"
  19. inherit autotools-brokensep ptest
  20. EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}'"
  21. do_install_ptest() {
  22. install -d ${D}${PTEST_PATH}
  23. cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
  24. sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
  25. }
  26. RDEPENDS_${PN}-ptest = "util-linux-getopt"
  27. COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'