xmlsec1_1.2.31.bb 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. SUMMARY = "XML Security Library is a C library based on LibXML2"
  2. DESCRIPTION = "\
  3. XML Security Library is a C library based on \
  4. LibXML2 and OpenSSL. The library was created with a goal to support major \
  5. XML security standards "XML Digital Signature" and "XML Encryption". \
  6. "
  7. HOMEPAGE = "http://www.aleksey.com/xmlsec/"
  8. DEPENDS = "libtool libxml2 libxslt zlib"
  9. LICENSE = "MIT"
  10. LIC_FILES_CHKSUM = "file://COPYING;md5=352791d62092ea8104f085042de7f4d0"
  11. SECTION = "libs"
  12. SRC_URI = "http://www.aleksey.com/xmlsec/download/${BP}.tar.gz \
  13. file://fix-ltmain.sh.patch \
  14. file://change-finding-path-of-nss.patch \
  15. file://makefile-ptest.patch \
  16. file://xmlsec1-examples-allow-build-in-separate-dir.patch \
  17. file://0001-nss-nspr-fix-for-multilib.patch \
  18. file://run-ptest \
  19. "
  20. SRC_URI[md5sum] = "182f5cbdfb8ddbac535c04470c170dc3"
  21. SRC_URI[sha256sum] = "9b10bc52cc31e4f76162e3975e50db26b71ab49c571d810b311ca626be5a0b26"
  22. inherit autotools-brokensep ptest pkgconfig
  23. #CFLAGS += "-I${STAGING_INCDIR}/nss3"
  24. #CPPFLAGS += "-I${STAGING_INCDIR}/nss3"
  25. PACKAGECONFIG ??= "gnutls libgcrypt nss openssl des"
  26. PACKAGECONFIG[gnutls] = ",,gnutls"
  27. PACKAGECONFIG[libgcrypt] = ",,libgcrypt"
  28. PACKAGECONFIG[nss] = "--with-nss=${STAGING_DIR_HOST} --with-nspr=${STAGING_DIR_HOST},--with-nss=no --with-nspr=no,nss nspr"
  29. PACKAGECONFIG[openssl] = ",,openssl"
  30. PACKAGECONFIG[des] = ",--disable-des,,"
  31. # these can be dynamically loaded with xmlSecCryptoDLLoadLibrary()
  32. FILES_SOLIBSDEV = "${libdir}/libxmlsec1.so"
  33. FILES_${PN} += "${libdir}/libxmlsec1-*.so"
  34. INSANE_SKIP_${PN} = "dev-so"
  35. FILES_${PN}-dev += "${libdir}/xmlsec1Conf.sh"
  36. FILES_${PN}-dbg += "${PTEST_PATH}/.debug/*"
  37. RDEPENDS_${PN}-ptest += "${PN}-dev"
  38. INSANE_SKIP_${PN}-ptest += "dev-deps"
  39. PTEST_EXTRA_ARGS = "top_srcdir=${S} top_builddir=${B}"
  40. do_compile_ptest () {
  41. oe_runmake -C ${S}/examples ${PTEST_EXTRA_ARGS} all
  42. }
  43. do_install_append() {
  44. for i in ${bindir}/xmlsec1-config ${libdir}/xmlsec1Conf.sh \
  45. ${libdir}/pkgconfig/xmlsec1-openssl.pc; do
  46. sed -i -e "s@${RECIPE_SYSROOT}@@g" ${D}$i
  47. done
  48. }
  49. do_install_ptest () {
  50. oe_runmake -C ${S}/examples DESTDIR=${D}${PTEST_PATH} ${PTEST_EXTRA_ARGS} install-ptest
  51. }