tigervnc_1.10.1.bb 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. DESCRIPTION = "TigerVNC remote display system"
  2. HOMEPAGE = "http://www.tigervnc.com/"
  3. LICENSE = "GPLv2+"
  4. SECTION = "x11/utils"
  5. DEPENDS = "xserver-xorg gnutls jpeg libxtst gettext-native fltk"
  6. RDEPENDS_${PN} = "coreutils hicolor-icon-theme perl"
  7. LIC_FILES_CHKSUM = "file://LICENCE.TXT;md5=75b02c2872421380bbd47781d2bd75d3"
  8. S = "${WORKDIR}/git"
  9. inherit features_check
  10. REQUIRED_DISTRO_FEATURES = "x11"
  11. inherit autotools cmake
  12. B = "${S}"
  13. SRCREV = "4739493b635372bd40a34640a719f79fa90e4dba"
  14. SRC_URI = "git://github.com/TigerVNC/tigervnc.git;branch=1.10-branch \
  15. file://0002-do-not-build-tests-sub-directory.patch \
  16. file://0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch \
  17. file://0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch \
  18. "
  19. # Keep sync with xorg-server in oe-core
  20. XORG_PN ?= "xorg-server"
  21. XORG_PV ?= "1.20.6"
  22. SRC_URI += "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${XORG_PV}.tar.bz2;name=xorg"
  23. XORG_S = "${WORKDIR}/${XORG_PN}-${XORG_PV}"
  24. SRC_URI[xorg.md5sum] = "a98170084f2c8fed480d2ff601f8a14b"
  25. SRC_URI[xorg.sha256sum] = "6316146304e6e8a36d5904987ae2917b5d5b195dc9fc63d67f7aca137e5a51d1"
  26. # It is the directory containing the Xorg source for the
  27. # machine on which you are building TigerVNC.
  28. XSERVER_SOURCE_DIR="${S}/unix/xserver"
  29. do_patch[postfuncs] += "do_patch_xserver"
  30. do_patch_xserver () {
  31. for subdir in Xext xkb GL hw/xquartz/bundle hw/xfree86/common; do
  32. install -d ${XSERVER_SOURCE_DIR}/$subdir
  33. done
  34. for subdir in hw/dmx/doc man doc hw/dmx/doxygen; do
  35. install -d ${XSERVER_SOURCE_DIR}/$subdir
  36. done
  37. sources="hw/xquartz/bundle/cpprules.in man/Xserver.man doc/smartsched \
  38. hw/dmx/doxygen/doxygen.conf.in xserver.ent.in xkb/README.compiled \
  39. hw/xfree86/xorgconf.cpp hw/xfree86/Xorg.sh.in"
  40. for i in ${sources}; do
  41. install -m 0644 ${XORG_S}/$i ${XSERVER_SOURCE_DIR}/$i;
  42. done
  43. cd ${XORG_S}
  44. find . -type f | egrep '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | \
  45. xargs tar cf - | (cd ${XSERVER_SOURCE_DIR} && tar xf -)
  46. cd ${XSERVER_SOURCE_DIR}
  47. xserverpatch="${S}/unix/xserver120.patch"
  48. echo "Apply $xserverpatch"
  49. patch -p1 -b --suffix .vnc < $xserverpatch
  50. }
  51. EXTRA_OECONF = "--disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
  52. --disable-xwin --disable-xephyr --disable-kdrive --with-pic \
  53. --disable-static --disable-xinerama \
  54. --with-xkb-output=${localstatedir}/lib/xkb \
  55. --disable-glx --disable-dri --disable-dri2 \
  56. --disable-config-hal \
  57. --disable-config-udev \
  58. --without-dtrace \
  59. --disable-unit-tests \
  60. --disable-devel-docs \
  61. --disable-selective-werror \
  62. --disable-xshmfence \
  63. --disable-config-udev \
  64. --disable-dri3 \
  65. --disable-libunwind \
  66. --without-xmlto \
  67. --enable-systemd-logind=no \
  68. --disable-xinerama \
  69. --disable-xwayland \
  70. "
  71. do_configure_append () {
  72. olddir=`pwd`
  73. cd ${XSERVER_SOURCE_DIR}
  74. rm -rf aclocal-copy/
  75. rm -f aclocal.m4
  76. export ACLOCALDIR="${XSERVER_SOURCE_DIR}/aclocal-copy"
  77. mkdir -p ${ACLOCALDIR}/
  78. if [ -d ${STAGING_DATADIR_NATIVE}/aclocal ]; then
  79. cp-noerror ${STAGING_DATADIR_NATIVE}/aclocal/ ${ACLOCALDIR}/
  80. fi
  81. if [ -d ${STAGING_DATADIR}/aclocal -a "${STAGING_DATADIR_NATIVE}/aclocal" != "${STAGING_DATADIR}/aclocal" ]; then
  82. cp-noerror ${STAGING_DATADIR}/aclocal/ ${ACLOCALDIR}/
  83. fi
  84. ACLOCAL="aclocal --system-acdir=${ACLOCALDIR}/" autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths || bbfatal "autoreconf execution failed."
  85. chmod +x ./configure
  86. ${CACHED_CONFIGUREVARS} ./configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
  87. cd $olddir
  88. }
  89. do_compile_append () {
  90. olddir=`pwd`
  91. cd ${XSERVER_SOURCE_DIR}
  92. oe_runmake
  93. cd $olddir
  94. }
  95. do_install_append() {
  96. olddir=`pwd`
  97. cd ${XSERVER_SOURCE_DIR}/hw/vnc
  98. oe_runmake 'DESTDIR=${D}' install
  99. cd $olddir
  100. }
  101. FILES_${PN} += " \
  102. ${libdir}/xorg/modules/extensions \
  103. ${datadir}/icons \
  104. "
  105. FILES_${PN}-dbg += "${libdir}/xorg/modules/extensions/.debug"