scsirastools_1.6.6.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Linux SCSi tools to service maintain disk storage devices"
  2. DESCRIPTION = "scsirastools were designed to add to the Serviceability of \
  3. SCSI devices under Linux so that the system does not have \
  4. to be rebooted or taken out of service to perform common \
  5. maintenance or service functions. It handles SCSI, \
  6. Linux SW RAID, SAS, SATA, and USB devices via SCSI emulation."
  7. HOMEPAGE = "http://scsirastools.sourceforge.net/"
  8. LICENSE = "BSD-3-Clause"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=687ea108478d26152ae46eb29d9d1545"
  10. DEPENDS += "groff-native"
  11. SRC_URI = "http://prdownloads.sourceforge.net/scsirastools/scsirastools-${PV}.tar.gz \
  12. file://mdadm.patch;apply=no \
  13. file://print-format.patch \
  14. "
  15. SRC_URI[md5sum] = "6271a61b2ce40aaf33ef61775148cda1"
  16. SRC_URI[sha256sum] = "e7b997e75decb06a650c42c35cd63d0c94c34e39cf133c723337b0eeabbfdf6a"
  17. inherit autotools update-rc.d
  18. # mdadm Makefile has CC set to gcc, hence override CC to ${CC}
  19. EXTRA_OEMAKE += "CC='${CC}'"
  20. do_configure_append() {
  21. oe_runmake -C mdadm.d mdadm-1.3.0
  22. patch -p0 < ${WORKDIR}/mdadm.patch
  23. }
  24. INITSCRIPT_PACKAGES = "${PN}-diskmon ${PN}-raidmon"
  25. INITSCRIPT_NAME_${PN}-diskmon = "sgdisk"
  26. INITSCRIPT_PARAMS_${PN}-diskmon = "defaults 80 20"
  27. INITSCRIPT_NAME_${PN}-raidmon = "sgraid"
  28. INITSCRIPT_PARAMS_${PN}-raidmon = "defaults 80 20"
  29. PACKAGES =+ "${PN}-diskmon"
  30. PACKAGES =+ "${PN}-raidmon"
  31. RPROVIDES_${PN}-dbg += "${PN}-diskmon-dbg ${PN}-raidmon-dbg"
  32. FILES_${PN}-diskmon = "${sbindir}/sgdiskmon ${sysconfdir}/init.d/sgdisk"
  33. FILES_${PN}-raidmon = "${sbindir}/sgraidmon ${sysconfdir}/init.d/sgraid"
  34. RDEPENDS_${PN} += "bash"
  35. RDEPENDS_${PN}-diskmon += "${PN} bash"
  36. RDEPENDS_${PN}-raidmon += "${PN} bash"