sblim-sfcb_1.4.9.bb 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687
  1. SUMMARY = "Small Footprint CIM Broker"
  2. DESCRIPTION = "\
  3. Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \
  4. Operations over HTTP protocol. It is robust, with low resource consumption \
  5. and therefore specifically suited for embedded and resource constrained \
  6. environments. sfcb supports providers written against the Common \
  7. Manageability Programming Interface (CMPI)."
  8. HOMEPAGE = "http://www.sblim.org"
  9. SECTION = "Applications/System"
  10. LICENSE = "EPL-1.0"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
  12. DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
  13. inherit distro_features_check
  14. REQUIRED_DISTRO_FEATURES = "pam"
  15. SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
  16. file://sfcb.service \
  17. file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
  18. file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \
  19. file://sblim-sfcb-1.3.16-maxMsgLen.patch \
  20. file://sblim-sfcb-1.4.5-service.patch \
  21. file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \
  22. file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \
  23. file://sblim-sfcb-1.4.9-fix-ftbfs.patch \
  24. file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \
  25. file://0001-Replace-need-for-error.h-when-it-does-not-exist.patch \
  26. "
  27. SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
  28. SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"
  29. inherit autotools
  30. inherit systemd
  31. SYSTEMD_PACKAGES = "${PN}"
  32. SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
  33. SYSTEMD_AUTO_ENABLE = "enable"
  34. LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
  35. EXTRA_OECONF = '--enable-debug \
  36. --enable-ssl \
  37. --enable-pam \
  38. --enable-ipv6 \
  39. CFLAGS="${CFLAGS} -D_GNU_SOURCE"'
  40. # make all with -j option is unsafe.
  41. PARALLEL_MAKE = ""
  42. INSANE_SKIP_${PN} = "dev-so"
  43. CONFIG_SITE = "${WORKDIR}/config-site.${P}"
  44. do_install() {
  45. cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg
  46. oe_runmake DESTDIR=${D} install
  47. install -d ${D}${systemd_unitdir}/system
  48. install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
  49. install -d ${D}${sysconfdir}/init.d
  50. mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb
  51. sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb
  52. rm -rf ${D}${libdir}/sfcb/*.la
  53. }
  54. pkg_postinst_${PN} () {
  55. OPTS=""
  56. if [ x"$D" != "x" ]; then
  57. OPTS="--root=$D"
  58. if type systemctl >/dev/null 2>/dev/null; then
  59. systemctl $OPTS ${SYSTEMD_AUTO_ENABLE} ${SYSTEMD_SERVICE}
  60. fi
  61. exit 1
  62. fi
  63. ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb
  64. ${bindir}/sfcbrepos -f
  65. }
  66. FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb"
  67. FILES_${PN}-dbg += "${libdir}/sfcb/.debug"
  68. RDEPENDS_${PN} = "perl bash"