abseil-cpp_git.bb 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. SUMMARY = "Abseil is a cpp library like STL"
  2. DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \
  3. additional useful libraries like algorithm, container, debugging, hash, memory, \
  4. meta, numeric, strings, synchronization, time, types and utility"
  5. HOMEPAGE = "https://abseil.io/"
  6. SECTION = "libs"
  7. LICENSE = "Apache-2.0"
  8. LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
  9. PV = "20190808+git${SRCPV}"
  10. SRCREV = "aa844899c937bde5d2b24f276b59997e5b668bde"
  11. BRANCH = "lts_2019_08_08"
  12. SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH} \
  13. file://0001-Remove-maes-option-from-cross-compilation.patch \
  14. file://0002-Add-forgotten-ABSL_HAVE_VDSO_SUPPORT-conditional.patch \
  15. file://0003-Add-fPIC-option.patch \
  16. file://0001-Add-RISCV-support-to-GetProgramCounter.patch \
  17. file://0001-absl-always-use-asm-sgidefs.h.patch \
  18. file://0001-Fix-build-on-riscv32.patch \
  19. "
  20. S = "${WORKDIR}/git"
  21. DEPENDS_append_libc-musl = " libexecinfo "
  22. ASNEEDED_class-native = ""
  23. ASNEEDED_class-nativesdk = ""
  24. inherit cmake
  25. BBCLASSEXTEND = "native nativesdk"
  26. ALLOW_EMPTY_${PN} = "1"
  27. python () {
  28. arch = d.getVar("TARGET_ARCH")
  29. if arch == "aarch64":
  30. tunes = d.getVar("TUNE_FEATURES")
  31. if not tunes:
  32. raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
  33. return
  34. pkgn = d.getVar("PN")
  35. pkgv = d.getVar("PV")
  36. if "crypto" not in tunes:
  37. raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
  38. if arch == "x86_64":
  39. tunes = d.getVar("TUNE_FEATURES")
  40. if not tunes:
  41. raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
  42. return
  43. pkgn = d.getVar("PN")
  44. pkgv = d.getVar("PV")
  45. if "corei7" not in tunes:
  46. raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
  47. }