phoronix-test-suite_9.2.1.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "Phoronix Test Suite"
  2. DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
  3. and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
  4. LICENSE = "GPLv3"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
  6. SECTION = "console/tests"
  7. SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
  8. SRC_URI[md5sum] = "ad80ed9a5835929138473f764ff0d5db"
  9. SRC_URI[sha256sum] = "675e7ca96719e2f3b42a6c13421213a398f04da0f8e78f4691fa9261fdeb8501"
  10. S = "${WORKDIR}/phoronix-test-suite"
  11. inherit systemd allarch mime mime-xdg
  12. do_install() {
  13. DESTDIR=${D} ./install-sh ${exec_prefix}
  14. if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
  15. install -d ${D}/${systemd_unitdir}/system/
  16. mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
  17. rm -rf ${D}/usr/lib/
  18. fi
  19. }
  20. # It is not advisable to enable these services by default since they can cause
  21. # continual target reboots if they encounter network problems.
  22. #
  23. SYSTEMD_AUTO_ENABLE = "disable"
  24. SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
  25. RDEPENDS_${PN} += "bash python3-core php-cli util-linux-lscpu os-release lsb-release"
  26. FILES_${PN} += " \
  27. ${datadir}/phoronix-test-suite \
  28. ${datadir}/appdata/phoronix-test-suite.appdata.xml \
  29. ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
  30. ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
  31. ${datadir}/mime/packages/openbenchmarking-mime.xml \
  32. ${systemd_unitdir}/* \
  33. "