dmalloc_5.5.2.bb 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. SUMMARY = "Debug Malloc Library"
  4. DESCRIPTION = "The debug memory allocation or dmalloc library has been \
  5. designed as a drop in replacement for the system's malloc, realloc, \
  6. calloc, free and other memory management routines while providing \
  7. powerful debugging facilities configurable at runtime. These facilities \
  8. include such things as memory-leak tracking, fence-post write detection, \
  9. file/line number reporting, and general logging of statistics."
  10. HOMEPAGE = "http://dmalloc.com/"
  11. LICENSE = "CC-BY-SA-3.0"
  12. LIC_FILES_CHKSUM = "file://dmalloc.c;beginline=4;endline=17;md5=83d13664f87f1f1a3b6b2b6f6eba85aa"
  13. SECTION = "libs"
  14. SRC_URI = "http://dmalloc.com/releases/dmalloc-${PV}.tgz \
  15. file://02-Makefile.in.patch \
  16. file://03-threads.patch \
  17. file://13-fix-ldflags-in-makefile.patch \
  18. file://configure-pagesize-HACK.patch \
  19. file://100-use-xtools.patch \
  20. file://130-mips.patch \
  21. file://150-use_DESTDIR.patch \
  22. file://0001-undefined-strdup-macro.patch \
  23. "
  24. SRC_URI[md5sum] = "f92e5606c23a8092f3d5694e8d1c932e"
  25. SRC_URI[sha256sum] = "d3be5c6eec24950cb3bd67dbfbcdf036f1278fae5fd78655ef8cdf9e911e428a"
  26. ARM_INSTRUCTION_SET = "arm"
  27. inherit autotools
  28. EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
  29. EXTRA_OECONF += "--enable-threads --enable-cxx --enable-shlib"