obconf_git.bb 742 B

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "Openbox configuration tool"
  2. AUTHOR = "Dana Jansens & Tim Riley & Javeed Shaikh"
  3. HOMEPAGE = "http://openbox.org/wiki/ObConf:About"
  4. SECTION = "x11/wm"
  5. LICENSE = "GPLv2+"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  7. DEPENDS = " \
  8. openbox \
  9. startup-notification \
  10. gtk+3 \
  11. "
  12. PV = "2.0.4+git${SRCPV}"
  13. SRCREV = "63ec47c5e295ad4f09d1df6d92afb7e10c3fec39"
  14. SRC_URI = " \
  15. git://git.openbox.org/dana/obconf \
  16. "
  17. S = "${WORKDIR}/git"
  18. inherit autotools gettext pkgconfig mime mime-xdg features_check
  19. # depends on openbox, which is X11-only
  20. REQUIRED_DISTRO_FEATURES = "x11"
  21. EXTRA_AUTORECONF = ""
  22. FILES_${PN} += "\
  23. ${datadir}/mime \
  24. "
  25. do_install_append () {
  26. rm -rf ${D}${datadir}/mimelnk
  27. }