xfce4-power-manager_1.6.0.bb 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. SUMMARY = "Power manager for the Xfce desktop environment"
  2. HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager"
  3. SECTION = "x11"
  4. LICENSE = "GPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
  6. inherit xfce distro_features_check
  7. REQUIRED_DISTRO_FEATURES = "x11"
  8. DEPENDS += "gtk+3 glib-2.0 dbus-glib xfconf libxfce4ui libxfce4util libnotify \
  9. libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver"
  10. SRC_URI[md5sum] = "2e2e24a1a22912d6a561ba6155887503"
  11. SRC_URI[sha256sum] = "bde3157e06ab31ff23648d163d53ee5095f7819544a9f48d3a96d57829857f2b"
  12. EXTRA_OECONF = " \
  13. --enable-network-manager \
  14. --enable-panel-plugins \
  15. "
  16. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
  17. PACKAGECONFIG[systemd] = "--enable-polkit, --disable-polkit, polkit"
  18. PACKAGES += "xfce4-powermanager-plugin"
  19. FILES_${PN} += " \
  20. ${datadir}/polkit-1 \
  21. ${datadir}/appdata \
  22. "
  23. FILES_xfce4-powermanager-plugin = " \
  24. ${libdir}/xfce4 \
  25. ${datadir}/xfce4 \
  26. "
  27. RDEPENDS_xfce4-powermanager-plugin = "${PN}"
  28. RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
  29. # xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin
  30. RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
  31. RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
  32. RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin"