cherokee_1.2.98.bb 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. SUMMARY = "Cherokee Web Server fast and secure"
  2. SUMMARY_cget = "Small downloader based in the Cherokee client library"
  3. HOMEPAGE = "http://www.cherokee-project.com/"
  4. SECTION = "network"
  5. LICENSE = "GPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  7. PR = "r9"
  8. DEPENDS = "libpcre openssl mysql5 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
  9. SRC_URI = "http://www.cherokee-project.de/mirrors/cherokee/1.2/${PV}/cherokee-${PV}.tar.gz \
  10. file://cherokee.init \
  11. file://cherokee.service \
  12. file://cherokee-install-configured.py-once.patch \
  13. "
  14. SRC_URI[md5sum] = "21b01e7d45c0e82ecc0c4257a9c27feb"
  15. SRC_URI[sha256sum] = "042b5687b1a3db3ca818167548ce5d32c35e227c6640732dcb622a6f4a078b7d"
  16. inherit autotools pkgconfig binconfig update-rc.d systemd
  17. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
  18. PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav"
  19. PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
  20. PACKAGECONFIG[geoip] = "--with-geoip,--without-geoip,geoip"
  21. PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
  22. EXTRA_OECONF = "--disable-static \
  23. --disable-nls \
  24. ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
  25. --with-wwwroot=${localstatedir}/www/cherokee \
  26. "
  27. do_install_append () {
  28. install -m 0755 -d ${D}${sysconfdir}/init.d
  29. install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee
  30. # clean up .la files for plugins
  31. rm -f ${D}${libdir}/cherokee/*.la
  32. install -d ${D}${systemd_unitdir}/system
  33. install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system
  34. rmdir "${D}${localstatedir}/run"
  35. rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
  36. }
  37. # Put -dev near the front so we can move the .la files into it with a wildcard
  38. PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget"
  39. FILES_cget = "${bindir}/cget"
  40. FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
  41. FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
  42. FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}"
  43. # Pack the htdocs
  44. FILES_${PN} += "${localstatedir}/www/cherokee"
  45. CONFFILES_${PN} = " \
  46. ${sysconfdir}/cherokee/cherokee.conf \
  47. ${sysconfdir}/init.d/cherokee \
  48. "
  49. INITSCRIPT_NAME = "cherokee"
  50. INITSCRIPT_PARAMS = "defaults 91 91"
  51. RPROVIDES_${PN} += "${PN}-systemd"
  52. RREPLACES_${PN} += "${PN}-systemd"
  53. RCONFLICTS_${PN} += "${PN}-systemd"
  54. SYSTEMD_SERVICE_${PN} = "cherokee.service"