openwbem_3.2.3.bb 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. SUMMARY = "Web Based Enterprise Management (WBEM) Implementation"
  2. DESCRIPTION = "OpenWBEM is a set of software components that help facilitate \
  3. deployment of the Common Information Model (CIM) and Web-Based \
  4. Enterprise Management (WBEM) technologies of the Distributed Management \
  5. Task Force (DMTF). \
  6. \
  7. Web-Based Enterprise Management (WBEM) is a set of management and \
  8. Internet standard technologies developed to unify the management of \
  9. distributed computing environments. WBEM provides the ability for the \
  10. industry to deliver a well-integrated set of standards-based management \
  11. tools, facilitating the exchange of data across otherwise disparate \
  12. technologies and platforms. \
  13. \
  14. For more information about DMTF and its technologies, visit \
  15. http://www.dmtf.org/standards. "
  16. SECTION = "System/Management"
  17. HOMEPAGE = "http://openwbem.sourceforge.net/"
  18. inherit autotools-brokensep pkgconfig
  19. SOURCE1="novell-openwbem-root-acl.mof"
  20. SOURCE2="loadmof.sh"
  21. SOURCE3="rmmof.sh"
  22. SOURCE4="openwbem-owcimomd.init"
  23. SOURCE5="openwbem-etc_pam.d_openwbem"
  24. SOURCE6="openwbem-rpmlintrc"
  25. SRC_URI = " \
  26. git://github.com/kkaempf/openwbem.git \
  27. file://${SOURCE1} \
  28. file://${SOURCE2} \
  29. file://${SOURCE3} \
  30. file://${SOURCE4} \
  31. file://${SOURCE5} \
  32. file://${SOURCE6} \
  33. file://checkserverkey \
  34. file://owcimomd.service \
  35. "
  36. SRCREV = "5c688eefc1f8e35a4b1c58529aae5f114c25c2a8"
  37. S = "${WORKDIR}/git"
  38. LICENSE = "BSD-3-Clause"
  39. LIC_FILES_CHKSUM += "file://COPYING;md5=0504a2eb85e01aa92c9efd4125a34660"
  40. INSANE_SKIP_${PN} = "dev-so"
  41. DEPENDS += "openssl libpam bash"
  42. RDEPENDS_${PN} += "bash"
  43. EXTRA_OECONF = " \
  44. --prefix=/usr \
  45. --sysconfdir=/etc \
  46. --libdir=${libdir} \
  47. --localstatedir=/var/lib \
  48. --libexecdir=${libdir}/openwbem/bin \
  49. --mandir=/usr/share/man \
  50. --enable-threads-run-as-user \
  51. "
  52. do_configure_prepend() {
  53. autoreconf --force --install
  54. }
  55. do_install() {
  56. oe_runmake DESTDIR=${D} install
  57. install -d ${D}/etc/openwbem/openwbem.conf.d
  58. install -d ${D}/var/adm/fillup-templates
  59. install -m 644 etc/sysconfig/daemons/owcimomd ${D}/var/adm/fillup-templates/sysconfig.owcimomd
  60. # fix up hardcoded paths
  61. sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/owcimomd.service
  62. if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
  63. install -d ${D}/${systemd_unitdir}/system
  64. install -m 644 ${WORKDIR}/owcimomd.service ${D}/${systemd_unitdir}/system
  65. install -m 755 ${WORKDIR}/checkserverkey ${D}${sysconfdir}/openwbem/
  66. fi
  67. install -d ${D}/etc/init.d
  68. ln -sf ../../etc/init.d/owcimomd ${D}/usr/sbin/rcowcimomd
  69. install -m 755 ${WORKDIR}/${SOURCE4} ${D}/etc/init.d/owcimomd
  70. install -d ${D}${sbindir}
  71. install -d ${D}/usr/bin
  72. install -d ${D}/etc/pam.d
  73. install -d ${D}/${libdir}/openwbem/cmpiproviders
  74. install -m 644 etc/pam.d/openwbem ${D}/etc/pam.d
  75. install -d ${D}/${libdir}/openwbem/c++providers
  76. install -d ${D}/var/lib/openwbem
  77. install -m 755 ${WORKDIR}/${SOURCE2} ${D}/usr/bin/ow-loadmof.sh
  78. install -m 755 ${WORKDIR}/${SOURCE3} ${D}/usr/bin/ow-rmmof.sh
  79. install -m 644 ${WORKDIR}/${SOURCE5} ${D}/etc/pam.d/openwbem
  80. MOFPATH=${D}/usr/share/mof/openwbem
  81. install -d $MOFPATH
  82. mv ${D}/usr/share/openwbem/* $MOFPATH/
  83. rmdir ${D}/usr/share/openwbem
  84. install -m 644 ${WORKDIR}/${SOURCE1} $MOFPATH/
  85. touch ${D}/var/lib/openwbem/{classassociation,instances,instassociation,namespaces,schema}.{dat,ndx,lock}
  86. }
  87. inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)}
  88. SYSTEMD_SERVICE_${PN} = "owcimomd.service"
  89. SYSTEMD_AUTO_ENABLE = "disable"
  90. FILES_${PN} += " \
  91. ${libdir} \
  92. ${datadir}/mof \
  93. ${systemd_unitdir} \
  94. "
  95. FILES_${PN}-dbg += " \
  96. ${libdir}/openwbem/c++providers/.debug \
  97. ${libdir}/openwbem/provifcs/.debug \
  98. ${libdir}/openwbem/bin/openwbem/.debug \
  99. "
  100. FILES_${PN}-dev = " \
  101. ${includedir} \
  102. ${datadir}/aclocal/openwbem.m4 \
  103. "
  104. # http://errors.yoctoproject.org/Errors/Details/68630/
  105. PNBLACKLIST[openwbem] ?= "BROKEN: fails to build with gcc-6"