terminus-font_4.38.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. SUMMARY = "Terminus fonts packages (console and X11)"
  2. DESCRIPTION = "Terminus Font is a clean, fixed width bitmap font, designed for \
  3. long (8 and more hours per day) work with computers."
  4. HOMEPAGE = "http://terminus-font.sourceforge.net/"
  5. AUTHOR = "Dimitar Zhekov"
  6. SECTION = "fonts"
  7. LICENSE = "OFL-1.1"
  8. LIC_FILES_CHKSUM = "file://OFL.TXT;md5=9cadb26f4c5c005618c5ae74f041ec54"
  9. DEPENDS = "hostperl-runtime-native gzip-native"
  10. SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
  11. SRC_URI[md5sum] = "a8e792fe6e84c86ed2b6ed3e2a12ba66"
  12. SRC_URI[sha256sum] = "f6f4876a4dabe6a37c270c20bb9e141e38fb50e0bba200e1b9d0470e5eed97b7"
  13. inherit allarch fontcache
  14. PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
  15. PACKAGECONFIG[x11] = ""
  16. # Don't use font cache mecanism for console packages
  17. FONT_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '${PN}-pcf', '', d)}"
  18. # Hand made configure script. Don't need oe_runconf
  19. do_configure() {
  20. chmod +x ${S}/configure
  21. ${S}/configure --prefix=${prefix} \
  22. --psfdir=${datadir}/consolefonts \
  23. --acmdir=${datadir}/consoletrans \
  24. --x11dir=${datadir}/fonts/terminus
  25. }
  26. do_compile() {
  27. oe_runmake DESTDIR=${D} psf txt ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'pcf', '', d)}
  28. }
  29. do_install() {
  30. oe_runmake DESTDIR=${D} install-psf install-acm ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'install-pcf', '', d)}
  31. }
  32. PACKAGES += "${PN}-consolefonts ${PN}-consoletrans ${PN}-pcf"
  33. FILES_${PN}-consolefonts = "${datadir}/consolefonts"
  34. FILES_${PN}-consoletrans = "${datadir}/consoletrans"
  35. FILES_${PN}-pcf = "${datadir}/fonts/terminus"
  36. PNBLACKLIST[terminus-font] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130638/"