fbida_2.10.bb 2.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. SUMMARY = "Framebuffer image and doc viewer tools"
  2. DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
  3. with the main focus being photos."
  4. HOMEPAGE = "http://linux.bytesex.org/fbida/"
  5. AUTHOR = "Gerd Hoffmann"
  6. SECTION = "utils"
  7. LICENSE = "GPLv2"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
  9. DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif"
  10. SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz"
  11. SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018"
  12. SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6"
  13. B = "${WORKDIR}/build"
  14. EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile"
  15. PACKAGECONFIG ??= "gif png curl"
  16. PACKAGECONFIG[curl] = ",,curl"
  17. PACKAGECONFIG[gif] = ",,giflib"
  18. PACKAGECONFIG[png] = ",,libpng"
  19. PACKAGECONFIG[tiff] = ",,tiff"
  20. PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
  21. PACKAGECONFIG[webp] = ",,libwebp"
  22. PACKAGECONFIG[lirc] = ",,lirc"
  23. do_compile() {
  24. sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile
  25. sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
  26. sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile
  27. # Be sure to respect preferences (force to "no")
  28. # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
  29. if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then
  30. sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
  31. fi
  32. if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then
  33. sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
  34. fi
  35. if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'png', d)}" ]; then
  36. sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
  37. fi
  38. if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'tiff', d)}" ]; then
  39. sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
  40. fi
  41. if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'motif', d)}" ]; then
  42. sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
  43. fi
  44. if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then
  45. sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
  46. fi
  47. if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then
  48. sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile
  49. fi
  50. oe_runmake
  51. }
  52. do_install() {
  53. oe_runmake 'DESTDIR=${D}' install
  54. }
  55. RDEPENDS_${PN} = "ttf-dejavu-sans-mono bash"
  56. PNBLACKLIST[fbida] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130677/"