sblim-sfcb_1.4.9.bb 2.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. SUMMARY = "Small Footprint CIM Broker"
  2. DESCRIPTION = "\
  3. Small Footprint CIM Broker (sfcb) is a CIM server conforming to the CIM \
  4. Operations over HTTP protocol. It is robust, with low resource consumption \
  5. and therefore specifically suited for embedded and resource constrained \
  6. environments. sfcb supports providers written against the Common \
  7. Manageability Programming Interface (CMPI)."
  8. HOMEPAGE = "http://www.sblim.org"
  9. SECTION = "Applications/System"
  10. LICENSE = "EPL-1.0"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
  12. DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
  13. SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
  14. file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
  15. file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \
  16. file://sblim-sfcb-1.3.16-maxMsgLen.patch \
  17. file://sblim-sfcb-1.4.5-service.patch \
  18. file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \
  19. file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \
  20. file://sblim-sfcb-1.4.9-fix-ftbfs.patch \
  21. file://sfcb.service"
  22. SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
  23. SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"
  24. inherit autotools
  25. inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)}
  26. SYSTEMD_PACKAGES = "${PN}"
  27. SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
  28. SYSTEMD_AUTO_ENABLE = "enable"
  29. LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
  30. EXTRA_OECONF = '--enable-debug \
  31. --enable-ssl \
  32. --enable-pam \
  33. --enable-ipv6 \
  34. CFLAGS="${CFLAGS} -D_GNU_SOURCE"'
  35. # make all with -j option is unsafe.
  36. PARALLEL_MAKE = ""
  37. INSANE_SKIP_${PN} = "dev-so"
  38. CONFIG_SITE = "${WORKDIR}/config-site.${P}"
  39. do_install() {
  40. cp -f ${S}/sfcb.cfg.pre.in ${S}/sfcb.cfg
  41. oe_runmake DESTDIR=${D} install
  42. if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
  43. install -d ${D}${systemd_unitdir}/system
  44. install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
  45. fi
  46. install -d ${D}${sysconfdir}/init.d
  47. mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb
  48. sed -i -e 's/\/var\/lock\/subsys\/sfcb/\/var\/lock\/subsys\/sblim-sfcb/g' ${D}${sysconfdir}/init.d/sblim-sfcb
  49. rm -rf ${D}${libdir}/sfcb/*.la
  50. }
  51. pkg_postinst_${PN} () {
  52. OPTS=""
  53. if [ x"$D" != "x" ]; then
  54. OPTS="--root=$D"
  55. if type systemctl >/dev/null 2>/dev/null; then
  56. systemctl $OPTS ${SYSTEMD_AUTO_ENABLE} ${SYSTEMD_SERVICE}
  57. fi
  58. exit 1
  59. fi
  60. ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb
  61. ${bindir}/sfcbrepos -f
  62. }
  63. FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb"
  64. FILES_${PN}-dbg += "${libdir}/sfcb/.debug"
  65. RDEPENDS_${PN} = "perl bash"