rarpd_ss981107.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. SUMMARY = "The RARP daemon."
  2. DESCRIPTION = "RARP (Reverse Address Resolution Protocol) is a protocol which \
  3. allows individual devices on an IP network to get their own IP addresses from \
  4. the RARP server. Some machines (e.g. SPARC boxes) use this protocol instead \
  5. of e.g. DHCP to query their IP addresses during network bootup. \
  6. Linux kernels up to 2.2 used to provide a kernel daemon for this service, \
  7. but since 2.3 kernels it is served by this userland daemon. \
  8. You should install rarpd if you want to set up a RARP server on your \
  9. network."
  10. SECTION = "System Environment/Daemons"
  11. SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/${BPN}/${BP}.tar.gz/be2a88f8ccddf2a40ac484cb3294fedc/${BP}.tar.gz"
  12. SRC_URI[md5sum] = "be2a88f8ccddf2a40ac484cb3294fedc"
  13. SRC_URI[sha256sum] = "4d6145d435a5d8b567b9798620f57f9b0a464078a1deba267958f168fbe776e6"
  14. SRC_URI += "file://0001-rarpd.8-add-man-file.patch \
  15. file://0002-Makefile-modify-compile-parameters.patch \
  16. file://0003-rarpd.c-bug-fix.patch \
  17. file://0004-rarpd.init-add-new-init-file.patch \
  18. file://0005-ethernet.c-remove-it.patch \
  19. file://ethers.sample \
  20. file://rarpd.service \
  21. "
  22. LICENSE = "GPLv2+"
  23. LIC_FILES_CHKSUM = "file://rarpd.c;md5=199b20b172ea93121bc613a9c77b6931"
  24. S = "${WORKDIR}/${BPN}"
  25. EXTRA_OEMAKE = "-e MAKEFLAGS="
  26. do_install() {
  27. install -d ${D}${sysconfdir}/init.d
  28. install -d ${D}${sbindir}
  29. install -d ${D}${mandir}/man8
  30. install -m 755 rarpd.init ${D}${sysconfdir}/init.d/rarpd
  31. install -m 755 rarpd ${D}${sbindir}/rarpd
  32. install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8
  33. install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers
  34. if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
  35. install -d ${D}${systemd_unitdir}/system
  36. install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/
  37. fi
  38. }
  39. inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)}
  40. SYSTEMD_PACKAGES = "${PN}"
  41. SYSTEMD_SERVICE_${PN} = "rarpd.service"
  42. SYSTEMD_AUTO_ENABLE = "disable"
  43. RDEPENDS_${PN} += "bash"