polkit_0.113.bb 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. SUMMARY = "PolicyKit Authorization Framework"
  2. DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
  3. HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
  4. LICENSE = "LGPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
  6. file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
  7. DEPENDS = "expat glib-2.0 intltool-native mozjs"
  8. inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection
  9. PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
  10. ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'consolekit', d)}"
  11. PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
  12. PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
  13. # there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
  14. PACKAGECONFIG[consolekit] = ",,,consolekit"
  15. PAM_SRC_URI = "file://polkit-1_pam.patch"
  16. SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
  17. file://0001-make-netgroup-support-configurable.patch \
  18. ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
  19. "
  20. SRC_URI[md5sum] = "4b77776c9e4f897dcfe03b2c34198edf"
  21. SRC_URI[sha256sum] = "e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81"
  22. EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages"
  23. do_compile_prepend () {
  24. export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
  25. }
  26. PACKAGES =+ "${PN}-examples"
  27. FILES_${PN}_append = " \
  28. ${libdir}/${BPN}-1 \
  29. ${nonarch_libdir}/${BPN}-1 \
  30. ${datadir}/dbus-1 \
  31. ${datadir}/${BPN}-1 \
  32. "
  33. FILES_${PN}-examples = "${bindir}/*example*"
  34. USERADD_PACKAGES = "${PN}"
  35. USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
  36. SYSTEMD_SERVICE_${PN} = "${BPN}.service"
  37. SYSTEMD_AUTO_ENABLE = "disable"