ltrace_git.bb 1.1 KB

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "ltrace intercepts and records dynamic library calls"
  2. DESCRIPTION = "ltrace intercepts and records dynamic library calls \
  3. which are called by an executed process and the signals received by that process. \
  4. It can also intercept and print the system calls executed by the program.\
  5. "
  6. HOMEPAGE = "http://ltrace.org/"
  7. LICENSE = "GPLv2"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
  9. PE = "1"
  10. PV = "7.3+git${SRCPV}"
  11. SRCREV = "01b10e191e99d8cb147e5a2b7da8196e0ec6fb94"
  12. DEPENDS = "elfutils"
  13. RDEPENDS_${PN} = "elfutils"
  14. SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=master \
  15. file://configure-allow-to-disable-selinux-support.patch \
  16. file://0001-replace-readdir_r-with-readdir.patch \
  17. "
  18. S = "${WORKDIR}/git"
  19. inherit autotools
  20. PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
  21. PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
  22. PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
  23. do_configure_prepend () {
  24. ( cd ${S}; ./autogen.sh )
  25. }