strongswan_5.5.1.bb 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. DESCRIPTION = "strongSwan is an OpenSource IPsec implementation for the \
  2. Linux operating system."
  3. SUMMARY = "strongSwan is an OpenSource IPsec implementation"
  4. HOMEPAGE = "http://www.strongswan.org"
  5. SECTION = "net"
  6. LICENSE = "GPLv2"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  8. DEPENDS = "gmp openssl flex-native flex bison-native"
  9. SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \
  10. file://fix-funtion-parameter.patch \
  11. "
  12. SRC_URI[md5sum] = "4eba9474f7dc6c8c8d7037261358e68d"
  13. SRC_URI[sha256sum] = "720b301991f77bdedd8d551a956f52e2d11686a0ec18e832094f86cf2b842ab7"
  14. EXTRA_OECONF = " \
  15. --without-lib-prefix \
  16. "
  17. EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
  18. PACKAGECONFIG ??= "charon curl gmp openssl stroke sqlite3 \
  19. ${@bb.utils.filter('DISTRO_FEATURES', 'ldap', d)} \
  20. "
  21. PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,"
  22. PACKAGECONFIG[charon] = "--enable-charon,--disable-charon,"
  23. PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
  24. PACKAGECONFIG[gmp] = "--enable-gmp,--disable-gmp,gmp,"
  25. PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap,"
  26. PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,"
  27. PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl,"
  28. PACKAGECONFIG[scep] = "--enable-scepclient,--disable-scepclient,"
  29. PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4,"
  30. PACKAGECONFIG[sqlite3] = "--enable-sqlite,--disable-sqlite,sqlite3,"
  31. PACKAGECONFIG[stroke] = "--enable-stroke,--disable-stroke,"
  32. PACKAGECONFIG[swanctl] = "--enable-swanctl,--disable-swanctl,,libgcc"
  33. # requires swanctl
  34. PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd,"
  35. inherit autotools systemd pkgconfig
  36. RRECOMMENDS_${PN} = "kernel-module-ipsec"
  37. FILES_${PN} += "${libdir}/ipsec/lib*${SOLIBS} ${libdir}/ipsec/plugins/*.so"
  38. FILES_${PN}-dbg += "${libdir}/ipsec/.debug ${libdir}/ipsec/plugins/.debug ${libexecdir}/ipsec/.debug"
  39. FILES_${PN}-dev += "${libdir}/ipsec/lib*${SOLIBSDEV} ${libdir}/ipsec/*.la ${libdir}/ipsec/plugins/*.la"
  40. FILES_${PN}-staticdev += "${libdir}/ipsec/*.a ${libdir}/ipsec/plugins/*.a"
  41. RPROVIDES_${PN} += "${PN}-systemd"
  42. RREPLACES_${PN} += "${PN}-systemd"
  43. RCONFLICTS_${PN} += "${PN}-systemd"
  44. SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'swanctl', '${BPN}-swanctl.service', '${BPN}.service', d)}"