ypbind-mt_1.38.bb 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # This package builds the NIS ypbind daemon
  2. # The source package is utils/net/NIS/ypbind-mt
  3. #
  4. require nis.inc
  5. DESCRIPTION = " \
  6. Multithreaded NIS bind service (ypbind-mt). \
  7. ypbind-mt is a complete new implementation of a NIS \
  8. binding daemon for Linux. It has the following \
  9. features. Supports ypbind protocol V1 and V2. \
  10. Uses threads for better response. Supports multiple \
  11. domain bindings. Supports /var/yp/binding/* file \
  12. for Linux libc 4/5 and glibc 2.x. Supports a list \
  13. of known secure NIS server (/etc/yp.conf) Binds to \
  14. the server which answered as first. \
  15. \
  16. This is the final IPv4-only version of ypbind-mt. \
  17. "
  18. HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
  19. DEPENDS = " \
  20. yp-tools \
  21. ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
  22. "
  23. RDEPENDS_${PN} += "yp-tools"
  24. # ypbind-mt now provides all the functionality of ypbind
  25. # and is used in place of it.
  26. PROVIDES += "ypbind"
  27. SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
  28. file://ypbind.init \
  29. file://ypbind.service \
  30. "
  31. SRC_URI[md5sum] = "094088c0e282fa7f3b3dd6cc51d0a4e1"
  32. SRC_URI[sha256sum] = "1930ce19f6ccfe10400f3497b31867f71690d2bcd3f5b575199fa915559b7746"
  33. inherit systemd update-rc.d
  34. SYSTEMD_SERVICE_${PN} = "ypbind.service"
  35. INITSCRIPT_NAME = "ypbind"
  36. INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
  37. CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
  38. do_install_append () {
  39. install -d ${D}${sysconfdir}/init.d
  40. install -d ${D}${sysconfdir}/rcS.d
  41. install -m 0755 ${WORKDIR}/ypbind.init ${D}${sysconfdir}/init.d/ypbind
  42. install -d ${D}${systemd_unitdir}/system
  43. install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
  44. }
  45. RPROVIDES_${PN} += "${PN}-systemd"
  46. RREPLACES_${PN} += "${PN}-systemd"
  47. RCONFLICTS_${PN} += "${PN}-systemd"