libtevent_0.9.31.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
  2. HOMEPAGE = "http://tevent.samba.org"
  3. SECTION = "libs"
  4. LICENSE = "LGPLv3+"
  5. DEPENDS += "libtalloc"
  6. RDEPENDS_python-tevent = "python"
  7. SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
  8. file://tevent-Add-configure-options-for-packages.patch \
  9. "
  10. LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=4e458d658cb25e21efc16f720e78b85a"
  11. SRC_URI[md5sum] = "5453847664ae6bc4ec0153e59ac635b9"
  12. SRC_URI[sha256sum] = "4a13f2256ad804c860e84068258bd0f8be31cf0c79aa8f3019fa32f6928c2bfc"
  13. inherit waf-samba
  14. PACKAGECONFIG ??= "\
  15. ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
  16. ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
  17. "
  18. PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
  19. PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
  20. PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
  21. PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
  22. PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
  23. PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
  24. SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
  25. S = "${WORKDIR}/tevent-${PV}"
  26. EXTRA_OECONF += "--disable-rpath \
  27. --bundled-libraries=NONE \
  28. --builtin-libraries=replace \
  29. --with-libiconv=${STAGING_DIR_HOST}${prefix}\
  30. --without-gettext \
  31. "
  32. PACKAGES += "python-tevent python-tevent-dbg"
  33. FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
  34. FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"