dovecot_2.2.25.bb 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. SUMMARY = "Dovecot is an open source IMAP and POP3 email server"
  2. DESCRIPTION = "Dovecot is an open source IMAP and POP3 email server for Linux/UNIX-like systems, written with security primarily in mind. Dovecot is an excellent choice for both small and large installations. It's fast, simple to set up, requires no special administration and it uses very little memory."
  3. SECTION = "mail"
  4. LICENSE = "LGPLv2.1 & MIT"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=a981379bd0f1c362f8d1d21515e5b30b"
  6. SRC_URI = "http://dovecot.org/releases/2.2/dovecot-${PV}.tar.gz \
  7. file://0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch \
  8. file://dovecot.service \
  9. file://dovecot.socket"
  10. SRC_URI[md5sum] = "8f62ea76489c47c369cbbe0b19818448"
  11. SRC_URI[sha256sum] = "d8d9f32c846397f7c22749a84c5cf6f59c55ff7ded3dc9f07749a255182f9667"
  12. DEPENDS = "openssl xz zlib bzip2 libcap icu"
  13. inherit autotools pkgconfig systemd useradd
  14. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ldap pam', d)}"
  15. PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
  16. PACKAGECONFIG[ldap] = "--with-ldap=plugin,--without-ldap,openldap,"
  17. PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
  18. # From native build in armv7a-hf/eglibc
  19. CACHED_CONFIGUREVARS += "i_cv_signed_size_t=no \
  20. i_cv_gmtime_max_time_t=32 \
  21. i_cv_signed_time_t=yes \
  22. i_cv_mmap_plays_with_write=yes \
  23. i_cv_fd_passing=yes \
  24. i_cv_c99_vsnprintf=yes \
  25. lib_cv___va_copy=yes \
  26. lib_cv_va_copy=yes \
  27. lib_cv_va_val_copy=yes \
  28. "
  29. # hardcode epoll() to avoid running unsafe tests
  30. # BSD needs kqueue and uclibc poll()
  31. EXTRA_OECONF = " --with-ioloop=epoll \
  32. --with-systemdsystemunitdir=${systemd_unitdir}/system"
  33. SYSTEMD_PACKAGES = "${PN}"
  34. SYSTEMD_SERVICE_${PN} = "dovecot.service dovecot.socket"
  35. SYSTEMD_AUTO_ENABLE = "disable"
  36. do_install_append () {
  37. install -d 755 ${D}/etc/dovecot
  38. touch 644 ${D}/etc/dovecot/dovecot.conf
  39. install -m 0644 ${WORKDIR}/dovecot.service ${D}${systemd_unitdir}/system
  40. sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/dovecot.service
  41. sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/dovecot.service
  42. }
  43. USERADD_PACKAGES = "${PN}"
  44. USERADD_PARAM_${PN} = "-r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovecot dovecot; \
  45. -r -d ${libexecdir} -M -s ${base_sbindir}/nologin -g dovenull dovenull"
  46. GROUPADD_PARAM_${PN} = "-f -r dovecot;-f -r dovenull"
  47. FILES_${PN} += "${libdir}/dovecot/*plugin.so \
  48. ${libdir}/dovecot/libfs_compress.so \
  49. ${libdir}/dovecot/libssl_iostream_openssl.so"
  50. FILES_${PN}-staticdev += "${libdir}/dovecot/*/*.a"
  51. FILES_${PN}-dev += "${libdir}/dovecot/libdovecot*.so"
  52. FILES_${PN}-dbg += "${libdir}/dovecot/*/.debug"