znc_git.bb 1.0 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "ZNC, an advanced IRC bouncer"
  2. SECTION = "net"
  3. LICENSE = "GPLv2"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
  5. DEPENDS = "openssl zlib icu"
  6. PV = "1.6.0"
  7. SRC_URI = "git://github.com/znc/znc.git;name=znc \
  8. git://github.com/jimloco/Csocket.git;destsuffix=git/third_party/Csocket;name=Csocket \
  9. "
  10. SRCREV_znc = "f47e8465efa4e1cd948b9caae93ac401b4355df8"
  11. SRCREV_Csocket = "07b4437396122650e5b8fb3d014e820a5decf4ee"
  12. # This constructs a composite revision based on multiple SRCREV's.
  13. #
  14. SRCREV_FORMAT = "znc_Csocket"
  15. S = "${WORKDIR}/git"
  16. inherit autotools-brokensep pkgconfig
  17. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
  18. PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
  19. # ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
  20. do_configure_prepend() {
  21. automake --add-missing || true
  22. }
  23. do_install_append() {
  24. sed -i 's/-fdebug-prefix-map[^ ]*//g; s#${STAGING_DIR_TARGET}##g' ${D}${libdir}/pkgconfig/*.pc
  25. }