dnrd_2.20.3.bb 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. SUMMARY = "A caching, forwarding DNS proxy server"
  2. DESCRIPTION = "\
  3. dnrd is a proxying nameserver. It forwards DNS queries to the appropriate \
  4. nameserver, but can also act as the primary nameserver for a subnet behind \
  5. a firewall. It also has features such as caching DNS requests, support for \
  6. DNS servers, cache poisoning prevention, TCP support, etc.."
  7. HOMEPAGE = "http://dnrd.sourceforge.net/"
  8. SECTION = "net"
  9. LICENSE = "GPLv2"
  10. LIC_FILES_CHKSUM = "file://COPYING;md5=0be67017f1c770313ad7b40e18d568f1"
  11. SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
  12. file://dnrd.service \
  13. file://dnrd.conf.sample \
  14. file://dnrd.init"
  15. SRC_URI[md5sum] = "41c9b070aae8ed403fc8c2aac7ab157c"
  16. SRC_URI[sha256sum] = "aa46e7f8736b88c1d752cf606b3990041221ce91d014e955c6b02eb2167db015"
  17. PNBLACKLIST[dnrd] ?= "BROKEN: dnrd-2.20.3-r0 do_package: QA Issue: dnrd: Files/directories were installed but not shipped in any package:"
  18. SYSTEMD_SERVICE_${PN} = "dnrd.service"
  19. SYSTEMD_AUTO_ENABLE = "disable"
  20. inherit autotools
  21. inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)}
  22. do_install() {
  23. oe_runmake install DESTDIR=${D} INSTALL="install -p"
  24. sed -i -e 's:/etc/rc.d/init.d/functions:/etc/init.d/functions:g' \
  25. ${WORKDIR}/dnrd.init
  26. install -d -m 0755 ${D}${sysconfdir}/init.d
  27. install -d -m 0755 ${D}${sysconfdir}/dnrd
  28. install -p -m 0644 ${WORKDIR}/dnrd.conf.sample ${D}${sysconfdir}/dnrd/dnrd.conf
  29. install -p -m 0755 ${WORKDIR}/dnrd.init ${D}${sysconfdir}/init.d/dnrd
  30. if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
  31. install -d -m 0755 ${D}${systemd_unitdir}/system
  32. install -m 644 ${WORKDIR}/dnrd.service ${D}${systemd_unitdir}/system
  33. fi
  34. }